LiveMotion、Intel+LeopardにOS9を使って起動。

(07.11.9)

私の管理しているホームページがあります。
仲間と作っている車のクラブのサイトです。
そろそろ更新しなきゃ・・と、制作するためのデータを探して・・あ、あったあった。あ〜・・これ、Adobe LiveMotion2.0の書類だ!!

最初の頃のデータを一部使い回しているので、Flash画像をLiveMotionで作ってる部分が
あるのでした(^^;
Flashで作り直そうにも、Flash2004しか持っていない。これ、IntelはおろかG5でも起動しないんですよね〜。

やっぱりLiveMotionしかないかぁ。
OS9はもとより、G4+Panther、G5+Tigerでも動いていたLiveMotion、きっとIntel iMac+Leopardでも動いてくれるに違いない!(ほとんどすがるような気持ち)

img_73467_51918409_0

作戦1:
で、まずは普通にインストール。早速「有効なClassic環境が見つかりませんでした」とアラート。
それがなんぼのもんじゃい!!続行です。
すると少しして今度は「インストール先にシステムフォルダが存在する必要があります」。インストールがキャンセルされてしまいました。

作戦2:
とりあえず起動できるか確認したい。
G4DigitalAudioを起動。LANでiMacからG4に接続、G4の起動ディスクをiMacにマウント。
そこで、マウントしたG4の起動ディスクからLiveMotionをダブルクリック。んんん!!起動しました。まあ、このまま使ってもいいかな〜とも
考えましたが、ぴん!とあることがひらめきました。

img_73467_51918409_1

作戦3:
要は、OS9のシステムフォルダがあればいい。
別にOS9起動なんかできなくても、存在していればいいんですよね、きっと。
そこで、OS9システムフォルダとLiveMotionを、G4からiMacにコピー。どれどれ、LiveMotionをダブルクリック!
・・あれ・・「接続に失敗しました。サーバが存在しないか・・云々」だそうです。

そうなんです。
さっきG4をiMacにマウントして起動した記録が、どこかに残ってるんですね。だから、もうiMac内にLiveMotionもOS9システムフォルダも両方とも
存在してるのにもかかわらず、LiveMotion起動するとわざわざ、「G4の起動ディスクに入ってる
OS9システムフォルダ」というのを探しに行っちゃうんですよねきっと。

img_73467_51918409_2

作戦4:
じゃあ、LiveMotionに「同じMac内にあるOS9システムフォルダを利用して起動する」ことを、覚えさせてやればいいってことですよね。
そこで今iMacにコピったLiveMotionとシステムフォルダを一旦消去。
もう一度G4を起動。
そしてG4上でLiveMotionを一度起動し、終了させます。これで「同じMac内にあるOS9システムフォルダを利用して起動」と記録されたはず。

あらためてiMacにG4をマウントし、OS9システムフォルダとLiveMotionを、iMacのアプリケーションフォルダにコピーして移植。
G4のマウントを解除し、LiveMotionをダブルクリック。
・・やったぁ!iMac+Leopard上で見事に起動。このあと、LiveMotionで作業をしましたが、問題なく作動してました。

OS-X上で起動するけど、OS9がないと作動しない、という過渡期にあったアプリケーションは、この「PowerPCのMacから、OS9システムフォルダを移植」してくることによって、Intel+Leopardで起動できるものが他にもあるかもしれませんね。

img_73467_51918409_3